Mendix Portal reduced functionality

Incident Report for Mendix Technology

Resolved

We've fixed the issue and nightly backups are getting created again for environments on the Mendix Cloud Free Tier
Posted May 14, 2025 - 08:41 UTC

Investigating

We're currently investigating an issue with nightly backups for environments on the Mendix Cloud Free Tier
Posted May 13, 2025 - 11:48 UTC
This incident affected: Mendix Cloud (Mendix Cloud Free Tier EU).