Sign-up processing issue

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 15:02 UTC

Identified

We are currently experiencing an issue with the processing of new signups, which is causing delays in the sending of confirmation emails. We are working to provide a fix for this as soon as possible. Platform functionality for existing accounts is unaffected by this issue.
Posted Mar 11, 2025 - 11:42 UTC
This incident affected: Mendix Services (Mendix Portal).