All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Mendix Portal degraded performance

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 08:20 UTC

Monitoring

The hotfix has been deployed and we're monitoring the results. Impacted customers can upload backups again.
Posted Jul 29, 2026 - 15:10 UTC

Update

The fix is taking longer than expected. We're planning to release this fix on 29 Jul at 1500 UTC as a hotfix. Unfortunately we cannot offer any workaround for uploading backups until the fix is released and we apologize for the inconvenience caused by this issue.
Posted Jul 28, 2026 - 15:50 UTC

Identified

The issue has been identified and we're working on a fix. We will provide updates as more information becomes available.
Posted Jul 28, 2026 - 13:52 UTC

Investigating

We are investigating an issue with Mendix Portal where customers may experience issues with uploading backups.

This incident will be updated in 1 hour, or as events warrant.
Posted Jul 28, 2026 - 12:09 UTC
This incident affected: Mendix Cloud Deployment (Backups).