All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Experiencing Mendix Platform signup issues

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Dec 20, 2022 - 21:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2022 - 16:22 UTC

Investigating

We are currently investigating this issue, new signups temporarily blocked
Posted Dec 20, 2022 - 13:27 UTC