All Systems are up and running

This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and a record of past incidents. Refer to the documentation for more information.

Licensing Service Hotfix

Incident Report for Mendix Technology

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 11:21 UTC

Investigating

We are currently investigating this issue.
Posted Feb 27, 2026 - 11:15 UTC
This incident affected: Mendix Services (Licensing Service).