This page provides a real-time overview of Mendix system status, details on upcoming scheduled maintenance, and
a record of past incidents. Refer to the
documentation for more information.
We will be undergoing scheduled maintenance during this time.
Posted Sep 24, 2026 - 11:04 UTC
Scheduled
We will be performing an update to our alerting stack on Mendix Cloud. During this maintenance window, alerting functionality may be temporarily unavailable.
Posted Sep 24, 2026 - 11:01 UTC
This scheduled maintenance affects: Mendix Cloud Regions (Mendix Cloud EU (Frankfurt), Mendix Cloud Free Tier EU, Mendix Cloud UK, Mendix Cloud IE, Mendix Cloud Africa (Cape Town), Mendix Cloud EU (Frankfurt 2)) and Mendix Cloud Dedicated Regions (Mendix Cloud Dedicated UK Echo, Mendix Cloud Dedicated EU (Frankfurt) Sierra, Mendix Cloud Dedicated EU (Frankfurt) Uniform, Mendix Cloud Dedicated US-East Colin, Mendix Cloud Dedicated EU (Frankfurt) Metro).